【iOS】Signing for requires a development team. Select a development team in the project editor. Code signing is required for product type ‘Application’ in SDK ‘iOS 10.0’

报错信息:Signing for “demo1_greating” requires a development team. Select a development team in the project editor.

Code signing is required for product type ‘Application’ in SDK ‘iOS 10.0’

解决方法:单击工程名 -》Signing -》 Team -》 选择对应的Account(如果没有Account,需要主动创建一个)

7a206aa2-7e5c-4d5f-98af-db07a1e26bc7

主动添加Account的方法请参考http://www.liuchuo.net/archives/284

【iOS】The run destination iPhone is not valid for Running the scheme .

错误信息如下:

The run destination iPhoneSE rational is not valid for Running the scheme ‘demo1_greating’.

iPhoneSE rational’s iOS 9.3.5 doesn’t match demo1_greating.app’s iOS 10.0 deployment target. Upgrade iPhoneSE rational’s iOS version or lower demo1_greating.app’s deployment target.

%e7%89%88%e6%9c%ac%e4%b8%8d%e5%8c%b9%e9%85%8d

解决方法:这是因为运行设置的版本系统和真机的系统版本不匹配导致的,所以只需要单击工程文件,在出现的设置里面的Deployment info -》 Deployment Target中选择对应的真机的系统即可~

qq20160916-02x